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or transmitted, in any form or by any means, electronic, mechanical, photocopying, recording, or otherwise, 
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Disclaimer 

This publication is provided "As Is" without warranty of any kind, either express or implied, including, but not 
limited to, the implied warranties of merchantability, fitness for a particular purpose, or non-infringement.  
Although every reasonable attempt has been made to insure accuracy, Hi*Tech assumes no responsibility for 
its use, nor for any infringements upon the rights of third parties that may result from its use. 
 
All technical and operational information incorporated into this manual is believed accurate and reliable as of 
the time of publication.  Changes are periodically added to the information contained herein.  These changes 
will be incorporated into new editions of the publication.  Hi*Tech reserves the right to make improvements to 
hardware, firmware, and software products at any time without public notice. 
 
To view any last minute changes, always refer to the Software Version Release Notes.  These release notes are 
the latest engineering notes regarding form, fit, and functionality. 
 
Finally, the system platform encompasses hardware technology from many different sources.  The operating 
system is Microsoft Windows®, and your LED display control software, firmware, and hardware are both 
proprietary and licensed. 
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Chapter 1 
Installation 

1.1 Introduction 
HX2 Control Panel is a software program that controls the operation of a Hi*Tech video LED display.  
The application can perform the following functions: 

• Turning the display on or off 
• Controlling the display brightness 
• Monitoring the temperature inside display modules 
• Adjusting display capture window 
• Adjusting display contrast 

1.2 Installation 
To install the application, place the HX2 Control Panel CD in your computer’s CD-ROM drive, 
initiate the installation by browsing your installation disk and double-clicking on the Setup program.  
The HX2 Control Panel Setup window will appear (Figure 1-1). 

 

 
Figure 1-1.  HX2 Control Panel Setup Window 

The HX2 Control Panel Setup Wizard will guide you through the installation process.  Click OK in 
the HX2 Control Panel Setup window to proceed.  The Directory Folder window will display (Figure 
1-2). 
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Figure 1-2.  Directory Folder Window 

The Directory Folder window displays where HX2 Control Panel is going to be installed on your 
computer.  If you would like to install the application in a different folder, click Change Directory 
and specify a new location. 

Click the install button at the top left of the window to continue on to the Choose Program Group 
dialog box (Figure 1-3). 

 
Figure 1-3.  Choose Program Group Dialog Box 

In the Program Group field, you can select to use the default option, enter a new group name, or 
select one from the Existing Groups list.  Click Continue to proceed with the next Choose Program 
Group dialog box (Figure 1-4). 
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Figure 1-4.  Choose Program Group Dialog Box 

In the Program Group field, you can select to use the default option, enter a new group name, or 
select one from the Existing Groups list.  Click Continue to proceed with the installation.  The 
progress of the installation will display in the Installation Progress window (Figure 1-5). 

 

 
Figure 1-5.  Installation Progress 

When the installation is complete the Install Completion window will appear (Figure1-6). 

 

 
Figure1-6.  Install Completion Message 

Click OK to exit the setup. 
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Chapter 2 
Getting Started 

2.1 Running the program 
If there is an HX2 Control Panel icon on the taskbar or the desktop, you can start the program by 
double-clicking the icon.  You can also start the program by selecting Start>Programs> HX2 
Control Panel>Control Panel from the taskbar.  Once the program starts, HX2 Control Panel the 
window displays (Figure 2-7). 

 
Figure 2-7.  HX2 Control Panel Window 

2.2 Menus and Toolbar 
By default, the toolbar and some menu items are hidden.  To show them, press Ctrl+Alt+Z (Figure 2-
8).  To hide the menus and toolbar buttons, repeat the same key stroke. 

 
Figure 2-8.  HX2 Control Panel Menus and Toolbar 

Expand button 

 
To expand or restore the operation window size, click the Expand button. 

Serial Port button 

 
To show or hide the serial port setting window, click the Serial Port button. 
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Testing Pattern button: 

 
To open the testing pattern window, click the Testing Pattern button. 

2.3 Serial Communication configuration 
NOTE: 

 

Please make sure that the VFC box is connected to an available serial port (RS232 port) of 
the control PC using the cable provided.  You may need a USB-RS232 converter if the 
control PC is not equipped with a RS232 port. 

In the HX2 Control Panel window, click the Serial Port button to display the Comm Port drop-down 
list box (Figure 2-9).  From the Comm Port list, select the serial port that you have connected to the 
VFC box. 

 
Figure 2-9.  Comm Port Drop-Down List Box View 

Once the serial port is set, click the Serial Port button to hide the Comm Port drop-down list box. 
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2.4 Turning the Display On/Off 
To turn the power of the LED display on, select the On option button, and to turn the power to the 
LED display off, select the Off option button (Figure 2-10).  This function is performed through a 
software switch for video data.  Original video data is passed to the display when it is turned on, and if 
the display is turned off zeros are sent instead. 

 
Figure 2-10.  HX2 Control Panel On/Off Controls 

2.5 Controlling the Brightness 
This overall display brightness can be set to one of the eight available levels.  The brightness level can 
be controlled in three modes. (Figure 2-11) 

 
Figure 2-11.  HX2 Control Panel Brightness Controls 
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Auto 

If you select the Auto option button, the brightness is controlled automatically by the reading 
of the ambient light sensor.  In this mode, the operator doesn’t have control over the 
brightness.  In order to use this mode, the ambient light sensor must be installed properly. 

Manual 

If you select the Manual option button, the brightness is controlled manually.  The display 
operator can select the appropriate brightness level by clicking the brightness level buttons on 
the left side of the window.  The top button represents the maximum brightness level. 

Schedule 

If you select the Schedule option button, the brightness is controlled by a schedule.  For more 
information on how to set the brightness schedule, see Chapter 3—Advanced Options 3.2 
Options Menu 3.2.2 Brightness Control Show Brightness Schedule Page. 

2.6 Setting the Contrast 
There are three contrast options: Low, Medium, and Optimal (Figure 2-12).  Using Optimal is highly 
recommended when showing video images on the display. 

 
Figure 2-12.  HX2 Control Panel Contrast Controls 

Double-clicking the Contrast button will switch the option to the next one in order. 
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2.7 Expanding the Application Window 
The application window can be expanded to show all the information or restored to present a 
simplified interface (Figure 2-13).  To switch between the two window sizes, click the Expand button. 

 
Figure 2-13.  Expanded HX2 Control Panel Window 

2.8 Displaying Test Patterns 
This function provides a quick and convenient way of showing test patterns or images on an LED 
display.  To display Test Pattern window, click the Testing Pattern button located on the toolbar 
(Figure 2-14). 

 
Figure 2-14.  Test Pattern Window 

To display a test pattern with the basic colors provided, click one of the color buttons.  After you 
select one of the options, the color will display on your monitor.  To display a test pattern by using a 
bitmap file, select the file to use from the file manager at the lower left corner of the window. 

To close the Test Pattern window, click the Exit button 
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2.9 Adjusting the Capture Window 
The LED display captures and shows part of the PC monitor.  The capture window has been adjusted 
properly before being shipped.  If readjustment is required during maintenance, please follow the 
instructions below. 

Expand the control panel window by clicking the Expand button on the toolbar (Figure 2-15). 

 
Figure 2-15.  HX2 Control Panel Capture Adjustment 

To adjust the x- and y- coordinates of the capture window, use the left, right, up, or down arrow 
buttons.  Once the LED display captures the intended area of the PC monitor, click the Save X Y 
button to save the x- and y- coordinate values into non-volatile memory in the VFC.  If the x- and y- 
coordinate values have been changed accidentally but not yet saved, clicking the Read X Y button can 
restore the old ones. 

The maximum x- and y- coordinate adjustment range is 255 pixels. 
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Chapter 3 
Advanced Options 

3.1 File Menu 
The File menu (Figure 3-16) enables you to open an existing configuration file or save a modified one.  
With the File menu, you can also view the software version or exit the program. 

 
Figure 3-16.  HX2 Control Panel File Menu 

Open 

To open an existing configuration file, select File>Open.  If there is a file currently opened 
and has not been saved, you will be prompted to save it. 

Save 

To save the current configuration file in its default location, select File>Save.  If the current 
file has not been previously saved, you will be prompted to input a file name. 

About 

To view the version number of the HX2 Control Panel installed on your computer, select 
File>About (Figure 3-17). 

 
Figure 3-17.  HX2 Control Panel Version Information 
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Exit 

To quit the HX2 Control Panel program, click the close button or select File>Exit.  Another 
way to quit the program is using the Control menu. 

3.2 Options Menu 
The Option menu (Figure 3-18) allows the user to configure various settings. 

 
Figure 3-18.  HX2 Control Panel Options Menu 

3.2.1 Thermal Profile 
Show Thermal Profile 

If you would like to view the thermal profile of the display, select Options> Thermal 
Profile>Show Thermal Profile.  The Thermal Monitor window will display (Figure 
3-19). 

 
Figure 3-19.  Thermal Monitor 

To avoid interfering with the display, this window should normally be minimized or 
closed. 
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3.2.2 Brightness Control 
Show Brightness Value Page 

To view the HX2 brightness values and threshold level, select Options>Brightness 
Control> Show Brightness Value Page.  The HX2 Light Values dialog box will 
display (Figure 3-20). 

NOTE: 

 

Unless advised by Hi*Tech, changing these values is not recommended.  
If the values have been changed accidentally, click the Restore Factory 
Settings button to go back to the original settings. 

 
Figure 3-20.  HX2 Light Values Dialog Box 

To return to the HX2 Control Panel window, click the Close button. 
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Show Brightness Schedule Page 

To set or review the brightness schedule, select Options> Brightness Control>Show 
Brightness Schedule Page.  The HX2 Schedule Brightness Page dialog box 
displays (Figure 3-21). 

 
Figure 3-21.  HX2 Schedule Brightness Page Dialog Box 

To create or modify the brightness schedule, specify the start time, stop time, and 
brightness level.  Once you have selected the start and end time and the brightness 
level, click Add to add the information to the list.  To place the times in the correct 
schedule order, click Sort. 

If you would like to remove any of the scheduled items from the list, click the 
Remove button next to the selected item. 

To return to the HX2 Control Panel window, click the Close button. 

3.2.3 Contrast 
Use this menu item to set the contrast to low, medium or optimal.  Setting the contrast to 
optimal is recommended when playing video programs on the LED display. 
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3.2.5 Set X–Y using the mouse 
The Set X-Y using the mouse feature allows you to quickly adjust the display capture 
window position.  Press F5 or select Options>Set X-Y using the mouse to display the X-Y 
Coordinate window (Figure 3-22). 

 
Figure 3-22.  X – Y Coordinate Window 

Place the pointer in the display window to select the coordinates.  Once you have placed the 
cursor in the video playing window, you can use the arrow keys to position the window at the 
exact coordinates. 

To set the coordinates, left click in the display or press Enter. 

If you decide not to set the new coordinates, right click in the display window or press to Esc 
to close the X – Y Coordinate window. 

3.2.5 Email 
E-mail 

The program can be set up to send e-mails to a list of people to report the status of the 
LED display.  Select Options>Email>E-Mail and a check mark ( ) will appear on 
the menu item indicating that the Email option is enabled. 

15  __/__/__ 
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E-mail Addresses 

The E-mail Addresses menu item allows you to set up a list of email recipients for 
the system status notification.  Select Options>Email>E-mail Addresses, the E-mail 
Addresses dialog box displays (Figure 3-23). 

 
Figure 3-23.  E-mail Addresses Dialog Box 

If you would like to add an e-mail to the list, enter the e-mail address in the Enter E-
Mail Address field and click Add to List.  The e-mail address will appear in the list 
box on the left of the window. 

To remove an e-mail address from the list box, select the address and click Delete 
selected address.  To return to the main program window, click the Close button. 

3.2.6 Timer Disable 
The Timer Disable option stops all transmission to the sign until communication is 
established once again with the sign.  To enable the Timer Disable option, select 
Options>Timer Disable. 

3.2.7 Global Only 
Enabling the Global Only option will make the PC broadcast communication commands, 
rather than talking to each module controllers individually.  To enable the Global Only 
option, select Options>Global Only. 
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Glossary 

CD 

See Compact Disc 

COM 

See Communication Port 

Communication Port 

A connector for a communications interface, usually, a serial port. 

Compact Disc 

Optical disc used for storing digital data. 

EIA-232 

Standard for serial binary data interchange between a DTE (Data terminal equipment) and 
DCE (Data communication equipment).  It is commonly used in personal computer serial 
ports. 

HX2 

Hi*Tech Video LED Display System 

LED 

See Light Emitting Diode 

Light Emitting Diode 

A semiconductor device that emits light when a current passes through it. 

PC 

See Personal Computer 

Personal Computer 

A computer with its own operating system and wide selection of software intended to be used 
by one person. 

Read Only Memory 

Memory whose contents can be accessed and read but cannot be changed. 

ROM 

See Read Only Memory 

RS-232 

See EIA-232 

Serial Port 

An interface that transmits data a bit at a time. 
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Universal Serial Bus 

Provides a serial bus standard for connecting devices to a computer. 

USB 

See Universal Serial Bus 

VFC 

Hi*Tech Video Format Converter 

VMC 

Hi*Tech Video Module Controller 

VRC 

Hi*Tech Video Row Controller 
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